Upload delays

Incident Report for Frame.io

Resolved

All media processing systems are fully operational. We're sorry for any troubles this may have caused. For questions, please reach out to our support team through the chat, or email support@frame.io.
Posted Oct 29, 2025 - 12:52 EDT

Update

Some assets may take longer than usual to be available as we continue to process more recent uploads. We are continuing to monitor.
Posted Oct 29, 2025 - 12:35 EDT

Monitoring

All backlogged uploads should now be processed. We are continuing to monitor.
Posted Oct 29, 2025 - 12:23 EDT

Update

A fix has been implemented, and backlogged uploads are processing.
Posted Oct 29, 2025 - 12:05 EDT

Identified

We have identified the root cause and are addressing issues with delayed uploads.
Posted Oct 29, 2025 - 12:02 EDT

Investigating

We are currently investigating an issue involving delayed uploading and transcoding. Our team is working to identify the root cause and implement a fix.
Posted Oct 29, 2025 - 11:05 EDT
This incident affected: next.frame.io (V4), app.frame.io (LEGACY), Developer Platform, and Media Processing.