Degraded software performance on processing uploads

Incident Report for Frame.io

Resolved

The incident has been resolved.
Posted Jul 14, 2026 - 12:52 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 14, 2026 - 12:15 EDT

Identified

We have identified the source of the issue and are actively working to mitigate.
Posted Jul 14, 2026 - 12:08 EDT

Investigating

Users are reporting slow processing when uploading files to their v4 accounts on Frame.io.
Posted Jul 14, 2026 - 05:30 EDT
This incident affected: next.frame.io (V4) and Media Processing.