Collection Viewing Outage

Incident Report for Frame.io

Resolved

This incident has been resolved.
Posted Jul 28, 2026 - 13:24 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2026 - 13:14 EDT

Investigating

Users were unable to view collections and some UI affordances were displayed incorrectly on the site,
Posted Jul 28, 2026 - 12:49 EDT
This incident affected: next.frame.io (V4).