Degraded software performance on processing uploads

Incident Report for Frame.io

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 16:41 EDT

Monitoring

All backlog jobs have been processed and we are resuming normal operations. We will continue to monitor while it is resuming.
Posted Jul 20, 2026 - 16:27 EDT

Update

We have identified the issue and have isolated the systems it is on. We are increasing other resources to help work through the backlog faster.
Posted Jul 20, 2026 - 16:11 EDT

Investigating

We are investigating reports of slow processing of new file uploads to v4 accounts on Frame.io.
Posted Jul 20, 2026 - 16:02 EDT
This incident affected: next.frame.io (V4) and Media Processing.