Degraded software performance

Incident Report for Frame.io

Resolved

The login issues have been resolved. We're sorry for the troubles this may have caused. For questions, please reach out to our support team through the chat, or email support@frame.io.
Posted Nov 04, 2025 - 12:27 EST

Monitoring

A fix has been implemented and we are actively monitoring.
Posted Nov 04, 2025 - 12:20 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 04, 2025 - 12:13 EST

Investigating

Some users are experiencing issues with logging into Frame.io via Adobe Auth. Our team is working to identify the root cause and implement a fix.
Posted Nov 04, 2025 - 12:06 EST
This incident affected: next.frame.io (V4) and app.frame.io (LEGACY).