Users intermittently unable to update billing information

Incident Report for Frame.io

Resolved

This issue has been resolved.
Posted Aug 23, 2022 - 11:10 EDT

Update

This issue has been resolved.
Posted Aug 23, 2022 - 11:09 EDT

Identified

We have identified an issue preventing users from updating their billing information. The issue is with our underlying payment and subscription provider. We will provide an update when they have supplied us with an ETA.
Posted Aug 22, 2022 - 14:30 EDT